注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

阁楼星空

透過天窗——仰望星空——遙望未來

 
 
 

日志

 
 

Routeros Adsl设置详解(含双线设置)  

2009-07-15 14:07:07|  分类: Routeros |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
这里以双线Adsl作为基本环境对Routeros进行相关的设置,包括adsl配置、共享上网设置、双线负载、双线分流、arp mac绑定等,所有设置均在winbox汉化版下进行,引号内为需要输入的内容。这个方法无论这两条线路是使用固定网关还是动态网关,无论是相同网关或是不同网关都能起到作用,是一个比较通用的做法,据说也是官方推荐的做法,希望对需要的人有所帮助。
网卡的基本设定为:lan表示内网网卡,wan1为第一条Adsl所在的网卡,wan2为第二条Adsl所在的网卡。

1. 设定PPPOE拨号:接口——Wan1(右键)——PPPOE客户端
普通的——名称——“pppoe-out1”——接口程序——wan1
拨出——填上adsl1的用户名和口令,勾选添加默认路由和使用同等dns。
最后按ok结束。然后设定第二条adsl,名称为"pppoe-out2",接口程序为wan2,只勾选添加默认路由。
2. 设定内网共享
(1)IP——防火墙——NAT,添加两条规则
第一条:普通的——链——(srcnat)——输出接口——(lan)将前面的方块点上!号
作用——(masquerade)
第二条:普通的——链——(srcnat)——源地址——“192.168.0.0/24”(这是内网的ip,按自己实际情况修改)
作用——(masquerade)
(2)IP——防火墙——Mangle,每条adsl添加两条规则
第一条:普通的——(forward)——协议——(6 (tcp))——接入接口——(pppoe-out1)
高级的——Tcp 标记——(syn)
作用——作用——(change MSS)——新的TCP MSS——“1440”
第二条:普通的——(forward)——协议——(6 (tcp))——输出接口——(pppoe-out1)
高级的——Tcp 标记——(syn)
作用——作用——(change MSS)——新的TCP MSS——“1440”
多条adsl以此类推。
到这一步已经可以共享上网了,不过要实现分流等功能还要继续。
3.设置ip地址
ip——地址        增加两个新的地址
第一个是pppoe-out1拨号后得到的外网ip,地址、网络、广播都填这个ip,借口选(pppoe-out1),注释为1。
第二个同理,全部为pppoe-out2的ip,注释为2。
主要目的是让路由能够找到自动添加的路由网关。
4.添加路由网关
ip——路由       增加三个网关
第一个:制定:0.0.0.0/0                 网关:(pppoe-out1的ip)           标志:1         注释:1
第二个:制定:0.0.0.0/0                 网关:(pppoe-out2的ip)           标志:2         注释:2
第三个:制定:0.0.0.0/0                 网关:(pppoe-out2的ip)           注释:2
第三个网上说是官方推荐增加的,具体原理现在不是太清楚。
5.双线负载规则
ip——防火墙——mangle             两条线就是增加四条规则,每两条为一对
第一组:第一条:普通的——链——(prerouting)——接入接口——(lan)——连接情形——(new)
                           附加——Nth——三个框分别是“1、1、0”
                           作用——作用——(mark connection)——新的连接标记——“1”
             第二条:普通的——链——(prerouting)——接入接口——(lan)——连接标志——“1”
                           作用——作用——(mark routing)——新的路由标记——“1”
第二组:第一条:普通的——链——(prerouting)——接入接口——(lan)——连接情形——(new)
                           附加——Nth——三个框分别是“1、1、1”
                           作用——作用——(mark connection)——新的连接标记——“2”
             第二条:普通的——链——(prerouting)——接入接口——(lan)——连接标志——“2”
                           作用——作用——(mark routing)——新的路由标记——“2”
这样就实现了双线平衡负载。
6.指定机器分流
如果要指定某些机器使用特定的线路访问外网,只要改造一下上面的规则就可以了,例如加上源地址。但是需要特别说明的是,这里的规则每一条的优先级都是一样的,而不是像防火墙过滤规则里那样是从上至下的,也就是说如果你设定的两个规则存在重复的部分,例如同样一个ip出现在两个规则里,那样就表明同时适用这两个规则,具体到底用哪个规则,就试验的情况看似会是交替其作用,所以应该尽量避免这种情况以避免不确定的事情发生。
7.自动更新网关的脚本
由于adsl拨号后ip会随即改变,这就需要定时监测ip的变化,在系统——脚本中添加下列脚本,名字这里设定为sadsl

:local assign-address
:local new-address
:local status
:local x
:set x 2
:for i from=1 to=$x do={
    :set status [/interface get [/interface find  name=("pppoe-out" . $i)] running]
    :if ($status=true) do={
     :set new-address [/ip address get [/ip address find dynamic=yes interface=("pppoe-out" . $i)] address]
     :set new-address [:pick $new-address 0 ([:len $new-address] -3)]
     :set assign-address [/ip address get [/ip address find dynamic=no interface=("pppoe-out" . $i)] address]
     :set assign-address [:pick $assign-address 0 ([:len $assign-address] -3)]
        :if ($assign-address != $new-address) do={ /ip address set [/ip address find comment=$i] address=$new-address network=$new-address broadcast=$new-address
        /ip route set [/ip route find comment=$i] gateway=$new-address
        /ip fir nat set [/ip fir nat find comment=$i] to-addresses=$new-address
        /ip route set [/ip route find comment=$i] gateway=$new-address
       }
   }
}

这个脚本同样适用2线以上的情况,只要改一下x的值。
在系统——调度程序中增加一个调度程序,间隔里输入具体的间隔时间,可以根据实际情况设定,但不建议设的间隔过长,因为时间过长的话重新拨号后就要等很久才能重新上网。而间隔时间过短的话又会造成路由器不停的查询ip加重服务器负担。
确定后整个设定就完成了。
  评论这张
 
阅读(551)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018